Back to overview
Downtime
New transactions not appearing in app
Mar 18, 2024 at 6:11pm UTC
Affected services
Production API
Resolved
Mar 18, 2024 at 6:52pm UTC
All services restored
Affected services
Created
Mar 18, 2024 at 6:11pm UTC
New transactions not appearing in app & users unable to log in
Affected services